JS判断浏览器是否是IE9版本以下

Joe  于  2017-03-08 16:49:09  发布至  编程相关  累计    次阅读

用JS判断浏览器是否是IE9以下,处理可能遇到的兼容性问题,或者给出浏览器版本过低的升级提醒。

    if(navigator.appName == "Microsoft Internet Explorer"&&parseInt(navigator.appVersion.split(";")[1].replace(/[ ]/g, "").replace("MSIE",""))<9){
        alert("您的浏览器版本过低,请下载IE9及以上版本");
    }


上一篇:C#用正则表达式替换邮箱或手机中间几位为*号下一篇:SQL分页查询 ROW_NUMBER高效率分页(仅支持MSSQL2005及以上)